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 PRAKTIKUM 03: TOMBOL DAN APLIKASINYA 

 

A. Pembuatan Tombol 

Selain tombol yang telah tersedia, kita dapat membuat tombol sendiri yang bentuk 

dan warnanya sesuai dengan selera. Langkah untuk membuat tombol adalah 

sebagai berikut. 

� Pilihlah Rectangle Tool, kemudian buatlah segiempat dengan sudut tumpul 

sebagai tombol. 

� Berikan isian warna untuk segiempat tersebut sesuai selera. 

� Ketik “TOMBOL” di dalam segiempat tersebut dan pilih warna teks yang kontras 

terhadap warna segiempatnya. 

� Pilih kotak beserta tulisannya, kemudian pilih menu Modify > Convert to Symbol, 

beri nama Tombol1 dan pilih type Button 

� Klik ganda Tombol kemudian akan tampil pada layar edit symbol empat buah 

frame: Up, Over, Down, dan Hit seperti gambar berikut. 

 

� Sisipkan Keyframe pada posisi Up, Over, Down, dan Hit 

� Pada frame Up, pilih teks “TOMBOL” kemudian ubah warna teks tersebut 

� Lakukan hal serupa untuk frame Over dan Down dengan warna yang lain 

� Kembali ke Editor Dokumen denga melakukan klik pada Scene 1 

� Lakukan Test Movie untuk tombol yang telah dibuat  
 
B. Contoh Penggunaan Tombol 

1. Tombol Play dan Stop 

� Buatlah file baru, pada layer 1 buatlah objek berupa bola dan ganti nama layer1 

menjadi Bola 

� Tambahkan layer baru, beri nama Pemantul 

� Pada layer Pemantul, buatlah gambar pemantul pada bagian kiri, kanan, atas, 

dan bawah 

� Pada frame 1 layer Bola lakukan klik kanan mouse kemudian pilih Create 

Motion Tween.   

� Sisipkan Keyframe pada frame 20 layer Bola 



Suharyanto, Seri Media Pembelajaran: Pembentukan Objek dan Animasi Menggunakan Flash 10 

 

� Pada frame 5, posisikan bola pada pemantul bawah 

� Pada frame 10, posisikan bola pada pemabtul kanan 

� Pada frame 15, posisikan bola pada pemantul atas 

� Pada frame 20, posisikan bola pada pemantul kiri 

� Tambahkan layer baru, beri nama Tombol 

� Buatlah tombol Play pada kiri bawah dan tombol Stop pada kanan bawah layer 

Tombol 

� Tampilan keseluruhan seperti gambar berikut 

 

 

� Pilih tombol Play, aktifkan Panel Actions kemudian isikan Script berikut 

on (release) { 

play (); 

} 

� Pilih tombol Stop, aktifkan Panel Actions kemudian isikan Script berikut 

on (release) { 

stop (); 

} 

� Lakukan Test Movie untuk melihat hasilnya 

 
2. Pull Down Menu 

� Buatlah file baru, ganti nama Layer 1 menjadi Menu 

� Buatlah tombol utama dengan tulisan “MENU”  

� Sisipkan Keyframe pada frame 2 

� Pada frame 2 buatlah tombol submenu: SK dan KD, Materi Ajar, dan Evaluasi 

dengan posisi urut ke bawah seperti gambar berikut. 
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� Pilih frame 1, aktifkan Panel Actions dan isikan Script berikut: 

stop (1); 

� Pada frame 1, pilih tombol MENU dan isikan Script pada Panel Actions: 

on (rollover) { 

gotoAndPlay (2); 

} 

� Copy frame 2 ke frame 3 

� Pilih frame, isikan script pada Panel Actions; 

stop (); 

� Pada frame 3 pilih tombol MENU dan isikan script pada Panel Actions: 

on (rollout) { 

gotoAndPlay (1); 

} 

� Lakukan Tes Movie untuk melihat hasilnya 
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 PRAKTIKUM 04: MEMBUAT MEDIA PEMBELAJARAN SEDERHANA 

 

A. Merancang Tampilan Awal 

Desain tampilan sederhana pada umumnya terdiri atas bagian untuk tombol 

Menu yang berisi tombol-tombol navigasi untuk menuju konten dan bagian 

Deskripsi Konten. Langkah-lankah untuk membuat tampilan awal adalah sebagai 

berikut: 

� Buka file baru, ganti nama Layer 1 menjadi Background. Pilih warna 

background sesuai selera. 

� Sisipkan frame pada frame 7 

� Sisipkan layer baru, beri nama Bingkai. Buatlah kotak untuk menempatkan 

menu dan deskripsi konten. Contoh tampilan seperti gambar 

 

� Buatlah layer Tombol. Buatlah tombol-tombol navigasi sebagai berikut: 

Pendahuluan, SK dan KD, Materi Ajar, Assesmen, dan Glosarium. 

� Untuk bagian deskripsi konten isikan: 

Pada frame 1 isikan PENDAHULUAN 
Pada frame 2 isikan MATERI AJAR 
Pada frame 3 isikan LATIHAN 
Pada frame 4 isikan ASSESMEN 
Pada frame 5 isikan GLOSARIUM 
Pada frame 6 isikan PROFILE 

 

� Contoh tampilan halaman depan seperti gambar di atas 

 



Suharyanto, Seri Media Pembelajaran: Pembentukan Objek dan Animasi Menggunakan Flash 13 

 

B. Action Script untuk Tombol Navigasi 

Contoh tombol dan pokok-pokok isi telah kita buat pada bagian A di atas. 

Selanjutnya kita akan memfungsikan tombol sesuai dengan tujuan yang 

diharapkan. 

� Frame 1 berisi judul media pembelajaran dengan tampilan menu yang akan 

tetap posisinya sebelum ditekan tombol tertentu. Pada Panel Action tuliskan 

script: 

stop (); 

� Pilih tombol PENDAHULUAN, tulis script: 

on (release) { 

gotoAndStop (2); 

} 

� Pilih tombol MATERI AJAR, tulis script: 

on (release) { 

gotoAndStop (3); 

} 

� Pilih tombol LATIHAN, tulis script: 

on (release) { 

gotoAndStop (4); 

} 

� Pilih tombol ASSESMEN, tulis script: 

on (release) { 

gotoAndStop (5); 

} 

� Pilih tombol GLOSARIUM, tulis script: 

on (release) { 

gotoAndStop (6); 

} 

� Pilih tombol PROFIL, tulis script: 

on (release) { 

gotoAndStop (1); 

} 

� Lakukan Tes Movie untuk melihat hasilnya 
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 PRAKTIKUM 05: MENYUSUN MATERI TAMPILAN  

 

A. Materi Berupa Teks 

Materi tampilan dapat berupa teks, gambar, movie dan gabungan dari dua unsur 

tersebut atau ketiga-tiganya. Untuk tampilan teks dapat diketik langsung maupun 

dicopy dari dokumen yang sudah ada. 

1. Materi diketik langsung 

� Pilih Text Tool, pada Properties pilih: Dynamic Text dan Multiline 

� Klik mouse dan drag untuk mengatur lebar kotak untuk teks pada stage dan 

lakukan pengetikan materi teks yang akan ditampilkan 

 
2. Materi Dicopy dari Dokumen 

� Pilih Text Tool, pada Properties pilih: Dynamic Text dan Multiline 

� Klik mouse dan drag untuk mengatur lebar kotak untuk teks pada stage  

� Buka dokumen yang akan diambil teksnya, pilih dan copy teks yang dikehendaki 

dan paste pada kotak teks pada stage. 

 
B. Materi Teks dan Gambar 

� Pilih Text Tool, pada Properties pilih: Dynamic Text dan Multiline 

� Klik mouse dan drag untuk mengatur lebar kotak untuk teks pada stage  

� Isikan teks pada kotak dengan cara mengetik atau mengcopy dari dokumen yang 

sudah ada 

� Untuk menyisipkan gambar, pilih menu File > Import to Stage 

� Pilih file gambar yang dikehendaki 

� Atur ukuran sesuai keperluan menggunakan Free Transform Tool 

� Contoh tampilan seperti gambar berikut 

 



Suharyanto, Seri Media Pembelajaran: Pembentukan Objek dan Animasi Menggunakan Flash 15 

 

C. Materi Teks dan Gambar Menggunakan Scroll Text 

Untuk materi teks dan gambar yang panjang tidak dapat ditampilkan dalam satu 

layar. Untuk itu disediakan fasilitas scroll text untuk pengaturannya. Langkah 

penggunaan scroll text adalah sebagai berikut. 

� Pilih Text Tool, pada Properties pilih  

Text Type: Dynamic Text 

Line Type: Multiline 

� Ketik teks sebanyak mungkin 

� Pilih menu Window > Components > User Interface > UIScrollbar 

� Klik dan drag UIScrollbar bawa ke stage dan lepaskan pada tulisan yang telah 

diketik 

� Persempit area teks kearah vertikal 

� Lakukan Tes Movie untuk melihat hasilnya seperti gambar berikut 

 

Untuk menampilkan Scroll Text dan gambar dilakukan dengan langkah sebagai 

berikut 

� Pilih menu Window > Components > User Interface >ScrollPane 

� Klik dan drag ScrollPane ke Stage 

� Perluas kotak ScrollPane secukupnya 

� Pilih kotak ScrollPane, buka panel Parameters dan ketik pada:  

ContentPath  : MateriScroll 

hLineScroll   : 5 

hPageScrollSize : 20 

� Pilih menu Insert > New Symbol 

� Pada kotak dialog Create New Symbol, ketik name : MateriScroll (harus sama 

dengan ContentPath) 
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� Pilih Linkage : Export for ActionScript 

� Ketik teks yang diperlukan dan sisipkan gambar dengan cara File > Import > 

Import to Stage 

� Atur posisi teks dan gambar di kanan bawah tanda Registration Point (+) 

� Contoh tampilan hasil Tes Movie seperti gambar berikut 

 
 

D. Materi Teks  dan Movie 

Selain materi pembelajaran berupa teks dan gambar, materi yang berupa suara dan 

movie dapat ditampilkan melalui Flash. Untuk menambahkan materi berupa movie 

dan suara dapat dilakukan dengan langkah-langkah berikut. 

� Pilih frame tempat ditampilkannya movie. 

� Pilih File > Import pilih file yang dikehendaki 

� Pada kotak dialog Import Video Setting, atur nilai setting jika diperlukan, 

kemudian klik tombol OK 

� Perbesar ukuran movie video sesuai keperluan 

� Lakukan test Movie untuk melihat hasilnya 

Untuk menambahkan suara lakukan langkah berikut 

� Pilih frame tempat ditampilkannya suara. 

� Pilih File > Import pilih file suara yang dikehendaki, import ke Library  

� Klik dan drag file suara ke Stage 

� Lakukan Test Movie untuk melihat hasilnya 

 

  



Suharyanto, Seri Media Pembelajaran: Pembentukan Objek dan Animasi Menggunakan Flash 17 

 

 PRAKTIKUM 06: MEMBUAT KUIS PILIHAN GANDA  

 

Media pembelajaran yang lengkap biasanya diberi latihan, kuis, atau asessmen. Salah 

satu model kuis sederhana berbentuk soal pilihan ganda. Untuk membuat soal pilihan 

ganda dilakukian langkah berikut. 

� Pada file baru buatlah: layer background, layer bingkai, dan layer soal 

� Pilih warna untuk layer background 

� Buat bingkai daerah penulisan soal pada layer bingkai. Contoh tampilannya seperti 

gambar berikut. 

 

� Pada frame 1 layer soal, buatlah informasi tentang kuis dan cara mengerjakannya. 

Pilih frame 1 dan berikan script: 

stop (); 

Buatlah tombol Lanjut untuk pindah ke frame 2, dan berikan script: 

on (release) { 

nextFrame (); 

} 

� Contoh tampilan sebagai berikut 
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� Pada frame 2 buatlah form pengisian identitas peserta tes, misalnya seperti tampilan 

berikut. 

 

Untuk tulisan: Nama, No. Siswa, dan Kelas; properties text adalah Static Text. 

Untuk kotak masukan nama, properties text adalah Input Text, Show border 

around text, dan nama variabel Nama 

Untuk kotak masukan No. Siswa, properties text adalah Input Text, Show border 

around text, dan nama variabel Nomor 

Untuk kotak masukan Kelas, properties text adalah Input Text, Show border 

around text, dan nama variabel Kelas 

Tombol Lanjut dapat dicopy dari frame 1 

� Pada frame 3 buatlah soal nomor 1 pilihan ganda dengan 4 opsi, antara pernyataan 

dan opsi-opsinya dalam kotak teks yang berbeda  

� Pilih opsi A ubahlah menjadi tombol, lakukan hal yang sama untuk opsi B, C, dan D 

� Pada frame 4 buatlah soal nomor 2 dan buatlah opsi-opsinya menjadi tombol 

� Buatlah soal 5 – 10 butir 

� Menulis Action Script 

Pada frame 3 soal 

stop(); 

skor = 0; 

Pada setiap opsi diberi 

on(release){ 

nextFrame(); 

} 

Khusus untuk opsi kunci ditambahkan script benar=benar + 1; sehingga menjadi: 

Pada opsi kunci soal nomor 1 (misal A) 

on(release){ 

benar = benar + 1; 

nextFrame(); 

} 

Static Text 
Input Text 
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Pada opsi kunci soal nomor 2 (misal C) 

on(release){ 

benar = benar + 1; 

nextFrame(); 

} 

Pada opsi kunci soal nomor 3 (misal B) 

on(release){ 

benar = benar + 1; 

nextFrame(); 

} 

� Lakukan hal serupa untuk soal-soal berikutnya 

 

Untuk membuat tampilan skor hasil tes gunakan langkah berikut 

� Setelah frame soal terakhir, sisipkan Blank Keyframe. Pilih Text Tool, tulis pada stage 

“SKOR HASIL TES” 

� Buatlah tampilan identitas ditambah skor ujian seperti tampilan berikut 

 
 

Untuk kotak tampilan nama, properties text adalah Dynamic Text, Show border 

around text, dan nama variabel Nama 

Untuk kotak fampilan No. Siswa, properties text adalah Dynamic Text, Show 

border around text, dan nama variabel Nomor 

Untuk kotak tampilan Kelas, properties text adalah Dynamic Text, Show border 

around text, dan nama variabel Kelas 

Untuk kotak tampilan Skor Ujian, properties text adalah Dynamic Text, Show 

border around text, dan nama variabel Skor 

� Lakukan Test Movie untuk melihat hasilnya 

Static Text Dynamic Text 


