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Introduksi

74 Kata tentang Flash

Diciptakan oleh Jonathan Gay di aplikasinya yang bernama SmartSketch untuk
PenPoint OS. Karena PenPoint tidak laku di pasaran maka SmartSketch dipindahkan
ke Microsoft Windows dan Mac OS. Dengan populernya internet SmartSketch
berubah nama menjadi CelAnimator, kemudian FutureSplash, animasi berbasis
vektor yang juga bersaing dengan Macromedia Shockwave. Tahun 1996
FutureSplash dibeli Macromedia dan diberi nama Flash, dari kata “Future” dan
“Splash”. Tahun 2005 Macromedia dibeli oleh Adobe dan kini Flash dikembangkan
dan didistribusikan oleh Adobe.

Peringatan
Crack itu termasuk melanggar etika lo



Mulai Ah

1. Buka aplikasi Adobe Flash.
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Mungkin tampilan yang ada akan berbeda sedikit dengan tampilan yang
kamu buka sekarang.

2. Pilih Create New > ActionScript 3.0

Tuing!

Apa sih bedanya ActionScript 3.0, ActionScript 2.0, dan tombol
menu di bawahnya itu? Sebenarnya sama aja kalau kamu mau
membuat animasi tanpa scripting. Yang membedakan adalah versi
bahasa ActionScript. Di modul ini kamu akan menggunakan
ActionScript 3.0

3. Jreng! Tampilannya akan seperti ini
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Tuing!

Jika kamu menggunakan aplikasi Adobe Flash CS5 dan ingin
membuat tampilan seperti ini klik workspace di kanan atas dan pilih

Mengubah ukuran stage

1. DiAdobe Flash CS5 hal ini sangatlah gampang, bener deh. Pertama klik

stage.

2. Ditab Properties bagian Size klik Edit...
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3. Nah, jendela Document Settings akan muncul. Ubah dimensions-nya
menjadi 300 (width) x 500 (height). Klik Ok, dan keajaiban pun terjadi.

4. Uwoh, ajaib, stagenya berubah ukuran.

=

Membuat lingkaran



1. Klik ta_han{ Rectaqglg Tool (alat yang bentuknya kotak). Pilih Oval Tool
u ®m || Rectangle Tool (R) .
‘ Q) Oval Tool (0) b
.d/f [ Rectangle Primitive Tool (R)
o8 =2 Oval Primitive Tool (O)

O PolyStar Tool
ol

2. Buat lingkaran di dalam stage. Terserah kamu mau sebesar apa dengan
warna apa, makin banyak kreasi yang kamu buat makin asoy.

3. Pilih bulatan tadi kemudian tekan F8 (Modify > Convert To Symbol) untuk
mengubahnya menjadi symbol. Jendela untuk mengatur symbol akan
muncul. Masukkan namanya bulat_mc dan Type nya Movie Clip



Convert to Symbol
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Tuing!

Sudah jadi tradisi untuk movie clip diberi nama belakangnya mc.
Sebenarnya tidak pun tidak apa-apa, diberi nama “Bulat_Asep” juga
boleh kok, hanya saja penamaan ini memudahkan untuk
pengembangan berikutnya.

Seperti Usagi Tsukino yang berubah mejadi Sailor Moon, kini bulatan yang
sudah kamu buat telah berubah menjadi movie clip. (Apa hubungannya
dengan Sailor Moon? Nggak, nggak ada, hanya saja roknya kependekan).
Tanda sebuah objek menjadi Movie Clip ketika di klik ada kotak biru di
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sekelilingnya.

5. Mari masuk ke dalamnya. Klik dua kali bulatan tadi. Kalau kamu
perhatikan sekarang kamu telah di dalam Movie Clip. Lihat, sekarang
tulisan di atas canvas ada Scene 1 dan disebelahnya ada bulat_mc.

= % Scene 1 bulat_mc

Tuing!
Tidaak! Aku ingin keluar dari bulatan ini! Tenang, tinggal klik tanda
panah ke kiri di atas atau klik Scene paling awal.

Urusan besar dan kecil

1. Punya kamu besar? Eh, maksudnya bulatannya, ingin
mengecilkannya? Atau membesarkannya? gampang. Pilih bulatan
kamu dan klik Free Transform Tool.

&3

q Free Transform Tool (Q)

2. Bulatan kamu akan dikelilingi kotak-kotak seperti ini. Tinggal drag dan
klik, seperti mengubah ukuran gambar di Office.




Menggerakkan Lingkaran
1. Letakkan lingkarannya di atas stage, seperti ini.
2. Dan masuk ke dalamnya. Sssehh!
3. Pada frame 30 klik kanan dan pilih Insert Keyframe

TIMELINE

PROPERTIE!

Create Motion Tween
Create Shape Tween
Create Classic Tween

Insert Frame
Remove Frames

Insert Keyframe
f @Bl 1200fs 00 Insert Blank Keyframe

al o g
X Untitled-1*
&) 5 Scene 1 bulat_mc

Clear Keyframe
Convert to Keyframes
Convert to Blank Keyframes

4. Blok frame 29 dan 30, klik kanan, dan pilih Create Classic Tween
35 40 45 50

[al - —

Create Motion Tween
Create Shape Tween
Create Classic Tween

5. Aha, lihat, sekarang jadi warna ungu yang imut seperti ini.
a0l 5 10 15 20 25

= Layer 1 4 e o+ AR :
|




6. Masih di Frame 30, pilih bulatan yang ada di stage dan drag hingga
ujung bawah stage, seperti ini.

+

Di draaaaag

7. Coba tekan Enter(di Windows) dan lihat! Bulatan itu secara ajaib
bergerak dengan sendirinya. Klenik sekali.
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8. Coba sekarang tekan Ctrl+Enter (di Windows) untuk Test Movie. Bisa
juga klik Control >Test Movie > Test.
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4 Loop Playback = =
9. Bola klenik itu pun melayang-layang di dalam jendela.

800 Untitled-1.swf

Lingkaran berbeda warna dengan Tint

1. Perbanyak lingkaran yang sudah kamu buat

2. Kalau warnanya sama kurang menarik yah? Pilih salah satu lingkaran, di
properties pilih Color Effect, Style, Tint. Kamu bisa mengubah warnanya




dari sini

x> COLOR EFFECT
Style: | Tint R |
Tint: © {) %
Red: () : E
Green: ° {} 153
Blue: L} i IE {
Tuing!

Jika ingin membuat movieclip yang sama tapi memiliki salah satu
bagian yang berbeda (misalnya warnanya) jangan edit movie clip itu
juga. Misalnya bola_mc bagian kanan kamu edit dengan masuk ke
dalamnya dan mengubah warnanya, bola_mc lainnya akan ikut
berubah karena semuanya sama-sama bola_mc. Jika ingin memiliki
movie clip yang berbeda kamu bisa menduplikasikannya terlebih
dahulu.

3. Lihat, lihat, warnanya sudah berbeda-beda.

Lingkaran Jatuh Bergantian
1. Pilih semua lingkaran tadi. Bisa dengan tahan shift dan klik satu-satu,

atau pilih selection tool (shortcutnya tombol “V”) | dan select
semua lingkaran dengan membloknya.

(@]

2. Klik kanan dan pilih “Convert To Symbol”. Kalau kamu perhatikan hal
ini sebenarnya sama dengan menekan tombol F8 (cara mengubah
menjadi Movie Clip).

3. Ubah Name nya menjadi banyak_bola_mc



4. Sekarang masuk ke dalamnya. Pilih semua lingkaran sekali lagi. Klik
kanan dan pilih Distribute To Layers.

Copy Motion
Copy Motion as ActionScript 3.0...
Paste Motion

Paste Motion Special...

y

Select All
Deselect All

Free Transform
Arrange b

Break Apart

Distribute to Layers

5. Apayang berubah? Nggak ada di stage, tapi coba lihat timelinenya,
jreeng! Setiap bulatan kini didistribusikan di layer yang berbeda. Layer
1 yang awalnya tempat lingkaran yang banyak tadi kini kosong.

s a0 S 10
Q] Layer 1 . o D
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6. Sekarang beri nama layer tersebut dan susun berdasarkan warnanya.
Perhatikan, frame yang kamu pilih maka seluruh objek di frame
tersebut akan terseleksi.

Tuing!

Untuk memberi nama layer cukup klik dua kali layer yang akan diberi nama.

@] Layer 1 e o [4

my
al bola hijau « « My
@l bola kuning e « [ \
@l bola biru e« W4

7. Pada layer bola merah pilih frame 10. Klik kanan dan klik “Insert
keyframe”. Pilih frame 5 dan hapus objek di dalamnya (tekan tombol
delete)

@ bola merah « « [ 0. UEI

8. Pilih layer bola hijau, beri keyframe di frame 7. Pilih Frame 10 dan klik
kanan, dan pilih “Insert Frame”. Pilih frame 6 dan hapus objek di




dalamnya

< bola hijau N Ofe !hl

9. Pilih layer bola kuning, beri keyframe di frarﬁe 4, beri frame di frame
10, dan hapus objek di frame 3.

= bola kuning 2 e e o DJ. ml
10. Pilih layer bola biru, beri frame di frame 10.
11. Fiuh, capek juga ya? Nah, sekarang frame dan layer akan tersusun
menjadi seperti ini

w bola merah e « [
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@] bola biru « « N

12. Kalau di Test Movie hasilnya aneh loh, ada bola yang turun sampai
bawah, ada yang hilang-hilang, nah sekarang saatnya sedikit script.
Beri keyframe di Layer 1 pada frame 10.

13. Masih di frame 10. Pilih Window > Actions (F9), ketikkan stop();

14. Dan secara ajaib ketika di Test Movie bola jatuh bergantian

Memasukkan Text

1. Kembali ke Stage yuk. Oh iya, kita belum memberi nama Layer 1. Ubah dulu
namanya menjadi bola bola.

2. Buat layer baru dengan mengklik tombol new Layer di kiri bawah bagian
Timeline. Taruh di atas layer bola bola, kemudian beri nama teks ILKOM

3. Masih di layer teks ILKOM. Pilih Text Tool (shortcutnya T). Klik bagian
tengah stage dan masukkan “ILKOM”.

4. Buat layer baru lagi dan beri nama teks SLOGAN.

5. Dilayer Teks SLOGAN masukkan teks “ilmu komputer”.

QU teks ILKOM « + M,
@ bola bola . . !!



ILKOM

iImu komputer

= B

Tuing!
Ingin mengubah besar tulisan? Fontnya juga? Gampang, tinggal ubah di bagian
Properties

Menggerakkan Text
1. Pilih teks ILKOM. Di layer teks ILKOM beri keyframe di frame 20. Blok
frame 19 dan 20 dan klik kanan, dan klik Create Classic Tween.



2. Kembali ke Frame 1 dan taruh tulisan ILKOM di bagian sebelah kanan
di luar stage seperti ini

ILKOM

iimu komputer

3. Sekarang pilih layer teks SLOGAN. Beri keyframe di frame 10 dan 20.
4. Hapus objek di frame 1.
5. Blok frame 20 dan 19, klik kanan dan pilih Create Classic Tween



6. Masih di layer teks SLOGAN di frame 10, pilih teks “ilmu komputer” di
stage dan drag hingga ke bagian sebelah kiri di luar stage seperti ini

ilmu komputer

7. Ahal Coba tekan enter, sekarang teks-teks itu melayang-layang. Ups,
tapi kok bola-bola yang sudah kita buat ikutan hilang ya? Itu karena
dia hanya muncul di frame 1. Agar muncul terus di layer bola bola
tambah frame nya di frame 20.

8. Cobain Test Movie. Wooow, ada teks yang gerak-gerak, ada bola yang
gerak-gerak, ajaib yah? Subhanallah.

Menambahkan background

1. Buat layer baru. Kalau letaknya di atas layer yang lain drag agar
letaknya di paling bawah. Ubah namanya jadi background.

a teks SLOGAN « « O, [1.>—>|II
a teks ILKOM e « W, >l
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qu : ) Do




2. Pilih rectangle tool (shortcutnya R). Buat kotak sebesar stage.
Ukurannya di tutorial ini sebesar 300 x 500.

Tuing!

Ingin ukurannya tepat dengan stage? Pilih kotak yang kamu buat, di properties
buat ukurannya sama dengan stage dan letaknya di (0,0)

3. Pada panel Color pilih Linear Gradient

J None
EX B
IV >

Solid color

Radial gradient
Bitmap fill

OB: 0%

OR: 0
Oc o
Os: 0
# A: 100%

—

Tuing!

Kalau panel color mu belum muncul pilih Window > Color

4. Ubah warnanya seperti ini, atau warna apapun yang kamu suka.
Untuk mengubahnya kamu bisa mengklik dua kali di tombol yang



berujung segitiga.
™ UuULLTrr R ‘

5. Aha, sekarang warna backgroundnya sudah ada. Tapi kamu ingin
mengubahnya gradasinya dari atas ke bawah? Bisa, pilih Gradient
Transform Tool (shortcutnya tombol F).

u = K% Free Transform Tool (Q)
ﬁ Gradient Transform Tool (F)

6. Klik di kotak background dan kamu bisa mengubah orientasi
gradasinya, bahkan mengubah ukurannya, tapi tidak terhadap
kotaknya. Keren kan? Sesuatu banget.

Tulisan Menjadi Warna Putih
1. Uh, warna merah dan biru tidak terlalu cocok di sini. Hm.. sekalian
deh diberikan efek kemunculan tulisannya. Di frame 20 pilih tulisan
ILKOM dan ilmu komputer.



2. Di bagian Properties, Color Effect pilih style Brightness dan ubah jadi

100%

Style:

= COLOR EFFECT

Brightness

|

Bright:

() [100]%

3. Dan kalau di play kemunculan tulisannya perlahan jadi putih

ILKOM

ilmu k&nputer

Memasukkan Gambar dan Menggerakkannya

1. Buat layer baru dan beri nama gambar. Taruh di atas layer bola bola.
2. Pilih File > Import > Import to Stage. Pilih gambar yang mau kamu

masukkan.

3. Letakkan di atas tulisan ILKOM. Oke, it’s looks great, tapi maunya
gerak-gerak, hehe. Di layer gambar tadi beri keyframe di frame 20.
Blok frame 19 dan 20 kemudian beri Classic Tween.

4. Kembali ke frame 1, letakkan gambar di bagian paling kiri di luar stage

seperti ini.




5. Pilih frame diantara frame 1 hingga 20 di layer gambar, misalnya
frame 9.

| = gambar s+ o H ' s|e
6. Pada properties bagian tweening, rotate, pilih CW. CW artinya
Clock-Wise (searah jarum jam).

w7 TWEENING
Ease: 0 &
Rotate: | CW |v|x 1

7. Coba di Play! Woa! Gambarnya muter-muter!

Efek Berhenti Sejenak

1. Setelah gerak maunya si gambar berhenti dulu sebentar. Nah, blok
frame 35 untuk seluruh layer.

Q) teks SLOGAN « « O, Ole —o— ¢ r
Q teks ILKOM e + W, I 1
@ gambar o o O >|0 I
4] bola bola « ¢ O I
e : ;j :

2. Klik kanan dan pilih Insert Frame (atau tekan F5) sehingga susunan
frame menjadi seperti ini.

W teks SLOGAN e « @, Do o i

Q) teks ILKOM e « W, | conoomnooooooeeoonooooonnn:

@) gambar o o [Os o 1 eooooneononuencaonoeaaDoonED
otk [

@ background .« M,

3. Ups, tulisannya kembali menjadi merah. Berilah keyframe pada frame
35 layer teks SLOGAN dan teks ILKOM

QU teks SLOGAN . o @, Oe > b 4
S . >e >

@ gambar o« o [ e~

@) bola bola « « O,

@ background « o O, ﬂ

Menghentikan Movie
1. Buat layer baru lagi dan beri nama script.
2. Beri keyframe di frame 35.



3. Buka Window > Actions (shortcutnya F9 di Windows).
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{5l Code Snippets N 2

1 stopQ)j|

4. Frame kita sudah seperti ini +4 yang ada tulisan a kecil nya, berarti
sudah ada action scriptnya. Coba di Test Movie (Ctrl+Enter). Movie
akan berhenti setelah di putar kecuali bola-bolanya. Ya, karena bola-
bola berada di Movie Clip dan yang kita hentikan adalah frame di
Movie luar. Movie Clip itu seperti Movie di dalam Movie.

Membuat Tombol
1. Nah, setelah berhenti pengen deh bisa diputar ulang. Oke, sekarang
buat layer baru dan beri nama tombol. Letakkan di bawah layer
script.
2. Beri keyframe di frame 35.
3. Beri kotak yang diberi tulisan “Putar Ulang” di atasnya.

Putar Ulang

4. Pilih kotak dan tulisan yang sudah kamu buat itu dan ubah menjadi
Symbol (tekan F8). Nah, sekarang kita tidak membuat Movie Clip, tapi
Button. Beri nama tombol ini sebagai replay_btn

. ConverttoSymbol

Name: [replay_btn | | ox |
Type: Registration:

Advanced ¥




5. Pilih tombol yang sudah kamu buat dan di bagian Properties beri
instance name dengan replay_btn

ITJIH [replay_btn | @

Button |

Instance of: replay_btn Swap...

6. Pilih layer script dan di frame 35 masukkan Actionscript ini

replay_btn.addEventListener(MouseEvent.CLICK, putar_lagi);

function putar_lagi(e:MouseEvent):void{
play(Q);

b

7. Aha! Sekarang coba deh di Test Movie. Movie akan berjalan dan
berhenti. Kalau kamu tekan button putar ulang maka movie akan



berjalan lagi.

IImu komputer

Putar Ulang

Fyuh, selesai



AKHIR

Keren ya Adobe Flash? Bila kamu ingin memilikinya bisa membelinya seharga
$699.00. Harga yang pantas untuk sebuah aplikasi yang hebat.

Sumber
http://en.wikipedia.org/wiki/Adobe_Flash
http://www.graphicmania.net/button-movieclip-actions-in-action-script-3/



